All Systems Operational
Kendo UI CDN Operational
90 days ago
100.0 % uptime
Today
Kendo UI Dojo Operational
90 days ago
100.0 % uptime
Today
Telerik Bower Operational
90 days ago
100.0 % uptime
Today
Telerik NuGet v3 Operational
90 days ago
99.87 % uptime
Today
Telerik NuGet v2 Operational
90 days ago
99.87 % uptime
Today
Telerik Forums Operational
90 days ago
100.0 % uptime
Today
Telerik Documentation Operational
90 days ago
100.0 % uptime
Today
Telerik Demos Operational
90 days ago
100.0 % uptime
Today
Telerik Unpkg CDN Operational
90 days ago
100.0 % uptime
Today
Telerik Reporting CDN ? Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Kendo UI Dojo
Fetching
Kendo UI Dojo Runner
Fetching
Kendo UI CDN
Fetching
Telerik Bower
Fetching
Telerik Forums
Fetching
Telerik NuGet v3
Fetching
Telerik NuGet v2
Fetching
Telerik Documentation
Fetching
Telerik Demos
Fetching
Telerik Unpkg CDN
Fetching
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024
Postmortem - Read details
Apr 9, 20:14 UTC
Resolved - The Telerik NuGet Server is back to full availability, even for affected environments. We will share a postmortem as soon as possible.
Apr 8, 19:57 UTC
Update - The network protection is still in place to ensure server availability throughout the incident. We are actively working with the datacenter's networking team and are continuing to monitor the situation.

Although his doesn't affect most users, it is very disruptive to the folks it does affect. For these folks, we have prepared recommend solutions to use during the event. Please visit https://gist.github.com/LanceMcCarthy/a79a14f6f8b20db335c639e16d0e6cfe#file-suggestions-md

Apr 8, 14:30 UTC
Update - We are still continuing to monitor the situation. The service itself is fully operational, however the servers are still behind additional networking protection services and a connection failure may be experienced. This is temporary, but make sure you're using a backoff interval that grows in duration upon each retry attempt.


It is still recommended that you add a packageSourceMapping to any nuget.config(s) in your project(s). This is a long term approach that will dramatically reduce the number of network requests your build is performing against the Telerik servers. See the previous update for a link to a code example.

Apr 5, 22:18 UTC
Monitoring - We have widened the network pipeline to the Telerik NuGet servers significantly, this should unblock many folks in those regions. Please try your builds again,

Tips:
- MAJOR TIP - Use a packageSourceMapping in your nuget.config to only use the Telerik NuGet Server for Telerik packages. A cross-product example can be found here => https://github.com/LanceMcCarthy/DevOpsExamples/blob/main/src/NuGet.Config (lines 31-47). This can significantly speed up your builds as a bonus.

- If you are triggering it immediately after this update notice and it fails, please consider that others teams may be trying at the same time as well. Add a short delay and try it again, avoid immediately retry it to let the post-update congestion tail off. This is more relevant if you have many parallel builds.

Apr 4, 21:34 UTC
Identified - Network protection is currently active to protect the servers from becoming unavailable for all customers.

[Edit] Removed request for individual build machine IPs, this is no longer a valid mitigation approach.

Apr 4, 15:53 UTC
Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024
Apr 4, 2024