NuGet Service Disruption (deprecated v2 server only)
Incident Report for Telerik
Postmortem

One of the nodes that handle NuGet server traffic was experiencing degraded performance. This caused a backlog of queued requests, which resulted in occasional 503 responses to any dotnet or nuget.exe client requesting use of the search or download API endpoints.

The node was investigated by the server team, repaired and operations returned to 100% capacity after the queue was flushed.

Posted Nov 11, 2021 - 18:42 UTC

Resolved
All Telerik NuGet servers are back at full operation.
Posted Nov 11, 2021 - 18:37 UTC
Update
The cause of disruption was identified and repaired. The servers are currently fulfilling queued requests in the backlog. We will update this status again when operations return to 100%.

Note: some new request responses may be slow, which might cause a timeout depending on your client. In such a case, rerun the restore command again after waiting several minutes.
Posted Nov 11, 2021 - 17:06 UTC
Update
We are continuing to investigate this issue.
Posted Nov 11, 2021 - 17:01 UTC
Investigating
We are currently investigating service disruption reports for the deprecated v2 NuGet server (https://nuget.telerik.com/nuget).

Note: There are no currently known issues with the new v3 NuGet server (https://nuget.telerik.com/v3/index.json). You can do an in-place swap of the server URLs to regain access to the feed.
Posted Nov 11, 2021 - 16:08 UTC
This incident affected: Telerik NuGet.