Telerik v3 NuGet Intermittent Outage

Incident Report for Telerik

Resolved

After monitoring for a few hours, we are confident the issue has been resolved.
Posted May 21, 2025 - 18:43 UTC

Monitoring

The issue has been identified and fixed. We will closely monitor for a few hours before marking this resolved.
Posted May 21, 2025 - 16:07 UTC

Investigating

We are currently investigating an issue with the Telerik NuGet service where 503 errors are return to dotnet SDK and nuget.exe requests (pings will succeed, REST requests will not).
Posted May 21, 2025 - 15:20 UTC
This incident affected: Telerik NuGet v3.