Telerik NuGet v3 Server Degraded Performance
Incident Report for Telerik
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 14:38 UTC
Monitoring
All nodes appear to be healthy. We are monitoring the performance.
Posted Mar 16, 2023 - 14:16 UTC
Identified
We have identified an issue with the NuGet v3 server and are working to resolve it.

Possible workarounds are:
- Use the NuGet v2 server https://nuget.telerik.com/nuget
- Download the required NuGet packages from http://telerik.com/account/downloads/ and use them from a local NuGet feed.
Posted Mar 16, 2023 - 14:09 UTC
This incident affected: Telerik NuGet v3.