Telerik NuGet
Incident Report for Telerik
Resolved
The service feed has returned to normal operation. Package listing, search and restore are back at full capacity.

Important Note: If you are using UI for Blazor, the Telerik.DataSource package requires an additional update. This will occur approximately ~9AM UTC.
Posted Mar 15, 2023 - 21:59 UTC
Update
Upgrading to Operational. We are continuing to closely monitor systems so that we can act quickly in the event of any unstable behavior.
Posted Mar 15, 2023 - 19:54 UTC
Update
Downgrading to Degraded Performance => When authenticating with or listing packages from the NuGet Server you may receive a timeout or an error stating "unable to load service index".

Tips:
- If you are experiencing this, wait a few minutes before attempting again.
- If you're using automatic retry, try adding a backoff delay.
Posted Mar 15, 2023 - 17:43 UTC
Monitoring
The issue has been resolved. We'll be closely monitoring the performance for the next few hours to ensure stability.
Posted Mar 15, 2023 - 15:29 UTC
Investigating
You may occasionally get an error "unable to load the service index" when restoring NuGet packages from the Telerik NuGet server. We are currently investigating and will keep you informed.
Posted Mar 15, 2023 - 14:12 UTC
This incident affected: Telerik NuGet v3 and Telerik NuGet v2.