Degraded Performance - High Demand

Incident Report for Telerik

Resolved

All server updates complete, services available at scale
Posted Jul 08, 2026 - 15:41 UTC

Monitoring

The Telerik NuGet server is under extremely high demand today, resulting in degraded performance. This may surface to you as a "503 (Service Unavailable)" error response. Just retry again with a modest incremental backoff.

For example, retry again immediately, if that fails, wait 20 seconds try again. This is a known, temporary, situation that we are addressing and closely monitoring.
Posted Jul 08, 2026 - 14:35 UTC
This incident affected: Telerik NuGet v3.