Telerik.com Your Account - Access Issues
Incident Report for Telerik
Resolved
This incident has been resolved. If you are still experiencing a problem, please perform a hard refresh of the page. Most browsers perform this if you A) hold the Shift key while clicking the browser's refresh button, or B) use Shift + Ctrl + R key combination.
Posted Nov 06, 2023 - 14:49 UTC
Investigating
We are currently investigating an issue where attempting to load any page under Your Account (licenses, downloads, support tickets) are unavailable.
Posted Nov 06, 2023 - 14:40 UTC